Servercommunity Foren-Übersicht Servercommunity
Das informative Forum für Fragen rund um Server
 
 FAQFAQ   SuchenSuchen   MitgliederlisteMitgliederliste   BenutzergruppenBenutzergruppen   RegistrierenRegistrieren 
 ProfilProfil   Einloggen, um private Nachrichten zu lesenEinloggen, um private Nachrichten zu lesen   LoginLogin 

"Relay access denied" beim Versenden an verschiede
Gehe zu Seite 1, 2, 3  Weiter
 
Neues Thema eröffnen   Neue Antwort erstellen    Servercommunity Foren-Übersicht -> Mail
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Harry
Crash Kid


Anmeldedatum: 21.06.2003
Beiträge: 1873

BeitragVerfasst am: So Okt 29, 2006 23:32    Titel: "Relay access denied" beim Versenden an verschiede Antworten mit Zitat

Ich hab da ein Problem, ein sehr dummes sogar ^^
Dieses Problem tritt von allen Kunden aus auf, allerdings nicht bei allen Adressaten.

So kann ich zB problemlos Mails von allen meinen eigenen Domains an mich selbst schicken, oder auch an *@s-c-t.de.
Schick ich aber zB meiner Sis eine Mail, sagt mir mein Webmail "Relay Access denied" (Outlook bekommt leider garnichts gesagt).

Folgender Eintrag findet sich dazu in der mail.log:

Zitat:
Oct 29 23:17:50 h1047751 postfix/smtpd[30139]: connect from localhost[::1]

Oct 29 23:17:50 h1047751 postfix/smtpd[30139]: NOQUEUE: reject: RCPT from localhost[::1]: 554 <gammlerin@hotmail.com>: Relay access denied; from=<mail@vinzenzfischer.de> to=<gammlerin@hotmail.com> proto=ESMTP helo=<h1047751.serverkompetenz.net>

Oct 29 23:17:50 h1047751 postfix/smtpd[30139]: lost connection after RCPT from localhost[::1]

Oct 29 23:17:50 h1047751 postfix/smtpd[30139]: disconnect from localhost[::1]


Problem tritt zB auch beim senden an *@online.de - Adressen auf.

Hat jemand ne zündende Idee, wo's da hängt?
Mein Chef ist ganz begeistert davon, dass man seinen SMTP-Server ja erstmal im Netz anmelden muss, auf allen möglich Listen. Hab ich noch nie von gehört, hab ich auch bei keinem meiner Server bisher gemacht... außerdem hat der doch eh keine Ahnung... oder doch?

Gruß,
Harry
_________________
Auf der Suche nach einer neuen Signatur...
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen
AndyG



Anmeldedatum: 29.06.2003
Beiträge: 603
Wohnort: Ruhrpott

BeitragVerfasst am: Mo Okt 30, 2006 10:03    Titel: Antworten mit Zitat

Hmm.., benutzt du als Authentifizierung "POP-before-SMTP"?
dann versuch mal erst Emails abzurufen und dann zu senden.

Wenn das dann geht kannst du in Outlook unter "Mein Postausgangsserver erfordert Authentifizierung" einen Haken machen, dann meldet Outlook sich vor dem senden der Mails erst am SMTP Server an.

Ist nur ne Vermutung Wink
_________________
Gruß
Andy

Das Leben ist gefährlich,.....,man kann dabei umkommen....!
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen
Harry
Crash Kid


Anmeldedatum: 21.06.2003
Beiträge: 1873

BeitragVerfasst am: Mo Okt 30, 2006 18:12    Titel: Antworten mit Zitat

Wäre eine Erklärung, ja - aber da das ganze ja (auch) beim Versenden vom Webmailer aus auftritt, liegt es sicher nicht daran
Außerdem ist das auth-Problem seit Outlook 2000 ja weitestgehend gelöst
_________________
Auf der Suche nach einer neuen Signatur...
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen
Dennis
Junior-Chef


Anmeldedatum: 21.06.2003
Beiträge: 2344
Wohnort: Schömberg (zw. Stuttgart u . Karlsruhe)

BeitragVerfasst am: Mo Okt 30, 2006 19:45    Titel: Antworten mit Zitat

paste mal bitte noch die /etc/postfix/main.cfg oder main.conf
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen
Harry
Crash Kid


Anmeldedatum: 21.06.2003
Beiträge: 1873

BeitragVerfasst am: Mo Okt 30, 2006 20:04    Titel: Antworten mit Zitat

Code:
broken_sasl_auth_clients = yes

# TLS Mode for SMTP-service
smtp_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_use_tls = yes
smtpd_tls_key_file = /etc/postfix/serverkey.pem
smtpd_tls_cert_file = /etc/postfix/servercert.pem
smtpd_tls_CAFile = /etc/postfix/cacert.pem
smtpd_tls_loglevel = 0
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom

# See /usr/share/postfix/main.cf.dist for a commented, more complete version

smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

myhostname = h1047751.serverkompetenz.net
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination = harrys-place.de, h1047751.serverkompetenz.net, localhost.serverkompetenz.net, localhost
relayhost =
mynetworks = 127.0.0.0/8
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all

maps_rbl_domains = relays.ordb.org
#smtp_recipient_restrictions = reject_maps_rbl, reject_unauth_destination, reject_unauth_pipelining
#smtp_client_restrictions = reject_maps_rbl, reject_unauth_destination, reject_unauth_pipelining
#smtp_sender_restrictions = reject_maps_rbl, reject_unauth_destination, reject_unauth_pipelining, reject_unknown_sender_domain, reject_non_fqdn_sender, reject_unknown_client, reject_non_fqdn_hostname
#smtp_sender_restrictions = permit_mynetworks, reject_unknown_sender_domain
smtpd_client_restrictions = reject_invalid_hostname, reject_rbl_client relays.ordb.org
strict_rfc821_envelopes = no
smtpd_recipient_restrictions = permit_mynetworks, reject_unknown_recipient_domain, permit_sasl_authenticated, reject_unauth_destination
smtpd_sender_restrictions = permit_mynetworks, reject_unknown_sender_domain, permit

#MailScanner
header_checks = regexp:/etc/postfix/header_checks


Mir ist noch eingefallen, dass ich beim umstellen der IPs bei Schlund für jede Domain dann auch jeweils die jeweilige Domain als Mailserver eingetragen hab - vorher stand bei jeder Domain "harrys-server.de" drin
_________________
Auf der Suche nach einer neuen Signatur...
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen
O.P.



Anmeldedatum: 21.06.2003
Beiträge: 835

BeitragVerfasst am: Di Okt 31, 2006 15:05    Titel: Re: "Relay access denied" beim Versenden an versch Antworten mit Zitat

Harry hat Folgendes geschrieben:
Dieses Problem tritt von allen Kunden aus auf, allerdings nicht bei allen Adressaten.

So kann ich zB problemlos Mails von allen meinen eigenen Domains an mich selbst schicken, oder auch an *@s-c-t.de.
Schick ich aber zB meiner Sis eine Mail, sagt mir mein Webmail "Relay Access denied" (Outlook bekommt leider garnichts gesagt).

Oct 29 23:17:50 h1047751 postfix/smtpd[30139]: NOQUEUE: reject: RCPT from localhost[::1]: 554 <gammlerin@hotmail.com>: Relay access denied; from=<mail@vinzenzfischer.de> to=<gammlerin@hotmail.com> proto=ESMTP helo=<h1047751.serverkompetenz.net>

Oct 29 23:17:50 h1047751 postfix/smtpd[30139]: lost connection after RCPT from localhost[::1]

Oct 29 23:17:50 h1047751 postfix/smtpd[30139]: disconnect from localhost[::1]


Problem tritt zB auch beim senden an *@online.de - Adressen auf.


Damit Webmail ohne SMTP-AUTH relayen darf musst du dies erlauben. Bei Sendmail geht das z.B. in der Datei etc/mail/access
localhost RELAY

Das wäre aber auch nur eine Erklärung wenn der Versand z.B. über Outlook (mit SMTP-AUTH) funktioniert, jedoch nicht per Webmail.

Mails an Empfänger auf dem gleichen Server nimmt Postfix natürlich immer an - das ist die Erklärung dafür, das du Mails an dich selbst schicken kannst, nur "relayen", also die Mail annehmen und an andere Server weiterleiten muss extra erlaubt werden.

Harry hat Folgendes geschrieben:

Mein Chef ist ganz begeistert davon, dass man seinen SMTP-Server ja erstmal im Netz anmelden muss, auf allen möglich Listen. Hab ich noch nie von gehört, hab ich auch bei keinem meiner Server bisher gemacht... außerdem hat der doch eh keine Ahnung... oder doch?


Einen Mailserver musst du nirgens vorher "anmelden".
Allerdings sollte er mindestens über eine feste IP-Adresse verfügen (viele Provider nehmen Mails nicht von Servern mit dynamischen IP-Adressen an - auch Server stehen manchmal zu hause) und die IP sollte per Reverse-DNS in einen Hostnamen auflösbar sein. Weiterhin sollte die IP auf keiner "Blacklist" stehen (Spamcop etc.)
Im Mode kommt auch (ist aber derzeit noch keine Pflicht) in den Zonenfiles der Domains die für die jeweilige Domain authorisierten mailserver einzutragen - eine sinnvolle Waffe gegen Spam wenn jeder mitmachen würde. Das wird aber wohl noch Zukunftsmusik sein - mir ist kein Provider bekannt der Mails blockt wenn der Eintrag nicht vorhanden ist.
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
Harry
Crash Kid


Anmeldedatum: 21.06.2003
Beiträge: 1873

BeitragVerfasst am: Di Okt 31, 2006 16:51    Titel: Re: "Relay access denied" beim Versenden an versch Antworten mit Zitat

[quote="O.P."]
Harry hat Folgendes geschrieben:
Das wäre aber auch nur eine Erklärung wenn der Versand z.B. über Outlook (mit SMTP-AUTH) funktioniert, jedoch nicht per Webmail.


Nein, das Problem (scheint) auch aus Outlook aus aufzutreten. Denn wenn ich aus Outlook an meine Sis schreibe, kommt diese nicht an - eine Rückmeldung bekomme ich aber nicht.
Was in diesem Fall dann im Log steht muss ich noch einmal schauen - dürfte ja aber kaum wirklich was andres sein
_________________
Auf der Suche nach einer neuen Signatur...
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen
Dennis
Junior-Chef


Anmeldedatum: 21.06.2003
Beiträge: 2344
Wohnort: Schömberg (zw. Stuttgart u . Karlsruhe)

BeitragVerfasst am: Di Okt 31, 2006 16:56    Titel: Antworten mit Zitat

ich hatte eigentlich mit thunderbird getestet und es ging, deshalb wundert mich das schon. vor allem habe ich die selbe konfiguration auch auf meinem server und da läufts auch, auch mit outlook....

http://www.heise.de/newsticker/meldung/80280 <- gelesen harry? Wink
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen
Harry
Crash Kid


Anmeldedatum: 21.06.2003
Beiträge: 1873

BeitragVerfasst am: Di Okt 31, 2006 19:19    Titel: Re: "Relay access denied" beim Versenden an versch Antworten mit Zitat

O.P. hat Folgendes geschrieben:
Damit Webmail ohne SMTP-AUTH relayen darf musst du dies erlauben. Bei Sendmail geht das z.B. in der Datei etc/mail/access
localhost RELAY

Das wäre aber auch nur eine Erklärung wenn der Versand z.B. über Outlook (mit SMTP-AUTH) funktioniert, jedoch nicht per Webmail.


hmm... da liegt wohl der Hund begraben.
Habe gerade mal bei meiner Sis ins Postfach geschaut - und die über Outlook versendeten Mails im SpamOrdner von Hotmail gefunden... *argh*
Kam ich aber auch nur drauf, weil es beim versenden über Outlook eben nicht zu einem Relay Denied Fehler in den Logs kam.

So weit, so gut.
Webmail-Relay auth muss ich noch mal mit Dennis klären, der kennt die entsprechende Stelle für Postfix sicher

Ein Problem bleibt noch: versenden mit Exchange funktioniert nicht immer:
Authentifizierung ist eingetragen, ne Mail an mail@vinzenzfischer.de kommt auch an, die Mail an vinzenz.fischer@s-c-t.de wird wieder nicht relayed.
Die selbe Config mit Telekom-Zugangsdaten tut ohne Probleme - kann hier auch serverseitig was "klemmen"?!
Wenn kein AUTH stattfindet, würde de Server die mail@vin... trotzdem zustellen, während er die ...@s-c-t.de blockiert?

Dennis hat Folgendes geschrieben:
http://www.heise.de/newsticker/meldung/80280 <- gelesen harry? Wink


Ja - und ebenfalls gut geflucht heute Morgen, weil ich natürich ebenfalls heute morgen ein letztes Komplettbackup ziehen wollte - und nur heute morgen an ne DSL16k-leitung ran kam
Nja, so mach ich es nun morgen früh...
_________________
Auf der Suche nach einer neuen Signatur...
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen
Dennis
Junior-Chef


Anmeldedatum: 21.06.2003
Beiträge: 2344
Wohnort: Schömberg (zw. Stuttgart u . Karlsruhe)

BeitragVerfasst am: Di Okt 31, 2006 19:22    Titel: Antworten mit Zitat

Webmail prüfen wir nochmal...spätestens am WE, die Exchange Geschichte sollten wir mal in den Logs verfolgen
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen
Harry
Crash Kid


Anmeldedatum: 21.06.2003
Beiträge: 1873

BeitragVerfasst am: Di Okt 31, 2006 19:27    Titel: Antworten mit Zitat

Webmail hat ja nun keine Eile

Logs... gute Idee ^^
_________________
Auf der Suche nach einer neuen Signatur...
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen
Harry
Crash Kid


Anmeldedatum: 21.06.2003
Beiträge: 1873

BeitragVerfasst am: Di Okt 31, 2006 19:37    Titel: Antworten mit Zitat

Zitat:
Oct 31 19:12:25 h1047751 postfix/smtpd[26345]: connect from p54A8A4D8.dip0.t-ipconnect.de[84.168.164.216]
Oct 31 19:12:25 h1047751 postfix/smtpd[26345]: NOQUEUE: reject: RCPT from p54A8A4D8.dip0.t-ipconnect.de[84.168.164.216]: 554 <vinzenz.fischer@s-c-t.de>: Relay access denied; from=<sct2@blubb.com> to=<vinzenz.fischer@s-c-t.de> proto=ESMTP helo=<blubb.local>
Oct 31 19:12:25 h1047751 postfix/smtpd[26345]: 77E666603A6: client=p54A8A4D8.dip0.t-ipconnect.de[84.168.164.216]
Oct 31 19:12:25 h1047751 postfix/cleanup[26348]: 77E666603A6: hold: header Received: from blubb.local (p54A8A4D8.dip0.t-ipconnect.de [84.168.164.216])??by h1047751.serverkompetenz.net (Postfix) with ESMTP id 77E666603A6??for <mail@vinzenzfischer.de>; Tue, 31 Oc from p54A8A4D8.dip0.t-ipconnect.de[84.168.164.216]; from=<sct2@blubb.com> to=<mail@vinzenzfischer.de> proto=ESMTP helo=<blubb.local>
Oct 31 19:12:25 h1047751 postfix/cleanup[26348]: 77E666603A6: message-id=<05AFAF34185F2F41BEF5133C320E01ED15FAD2@blubb.local>
Oct 31 19:12:25 h1047751 postfix/smtpd[26345]: disconnect from p54A8A4D8.dip0.t-ipconnect.de[84.168.164.216]
Oct 31 19:12:26 h1047751 MailScanner[23394]: New Batch: Scanning 1 messages, 2486 bytes
Oct 31 19:12:27 h1047751 MailScanner[23394]: Virus and Content Scanning: Starting
Oct 31 19:12:29 h1047751 MailScanner[23394]: Requeue: 77E666603A6.02DC7 to A37546603A9
Oct 31 19:12:29 h1047751 postfix/qmgr[25800]: A37546603A9: from=<sct2@blubb.com>, size=2241, nrcpt=1 (queue active)
Oct 31 19:12:29 h1047751 MailScanner[23394]: Uninfected: Delivered 1 messages
Oct 31 19:12:29 h1047751 MailScanner[23394]: MailScanner child dying of old age
Oct 31 19:12:29 h1047751 postfix/virtual[26357]: A37546603A9: to=<mail@vinzenzfischer.de>, relay=virtual, delay=4, status=sent (delivered to maildir)
[/code]

Hab mal den Namen des loclaen Servers verfremdet ^^
_________________
Auf der Suche nach einer neuen Signatur...
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen
O.P.



Anmeldedatum: 21.06.2003
Beiträge: 835

BeitragVerfasst am: Di Okt 31, 2006 19:43    Titel: Re: "Relay access denied" beim Versenden an versch Antworten mit Zitat

Harry hat Folgendes geschrieben:

Ein Problem bleibt noch: versenden mit Exchange funktioniert nicht immer:
Authentifizierung ist eingetragen, ne Mail an mail@vinzenzfischer.de kommt auch an, die Mail an vinzenz.fischer@s-c-t.de wird wieder nicht relayed.
Die selbe Config mit Telekom-Zugangsdaten tut ohne Probleme - kann hier auch serverseitig was "klemmen"?!
Wenn kein AUTH stattfindet, würde de Server die mail@vin... trotzdem zustellen, während er die ...@s-c-t.de blockiert?

Wenn dein Server für die Domain "vinzenzfischer.de" zuständig ist (in der Konfig eingetragen) wird er Mails für existiere User dieser Domain auch ohne SMTP-AUTH annehmen, er ist ja selbst der Server wo die Mails hin müssen. Wenn er eine Mail für eine nicht lokal konfigurierte Domain (z.B. "s-c-t.de" ??) ist er selbst ja nicht der Server, wo die Mails hinmüssen, sondern nur ein Durchgangsserver (Relay), der die Nachrichten annimmt und an den eigendlichen, für die Domain zuständigen Mailserver weiterleitet. Dafür braucht er (hoffendlich) SMTP-AUTH, so dass nur berechtigte User Mails über deinen Server an Dritte versenden können.

Wo ist denn Exchange installiert? Auf deinem Server?
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
Harry
Crash Kid


Anmeldedatum: 21.06.2003
Beiträge: 1873

BeitragVerfasst am: Di Okt 31, 2006 19:47    Titel: Re: "Relay access denied" beim Versenden an versch Antworten mit Zitat

O.P. hat Folgendes geschrieben:
Wo ist denn Exchange installiert? Auf deinem Server?


Nein, hier handelt es sich um einen Server beim Kunden vor Ort (ist ein MS Exchange 2000)

Also klappt die Anmeldung nicht... hmm
_________________
Auf der Suche nach einer neuen Signatur...
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen
Dennis
Junior-Chef


Anmeldedatum: 21.06.2003
Beiträge: 2344
Wohnort: Schömberg (zw. Stuttgart u . Karlsruhe)

BeitragVerfasst am: Di Okt 31, 2006 19:49    Titel: Antworten mit Zitat

die log sieht aus als wäre der user nicht geauthed
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen
Beiträge der letzten Zeit anzeigen:   
Neues Thema eröffnen   Neue Antwort erstellen    Servercommunity Foren-Übersicht -> Mail Alle Zeiten sind GMT + 1 Stunde
Gehe zu Seite 1, 2, 3  Weiter
Seite 1 von 3

 
Gehe zu:  
Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.



Powered by phpBB © 2001, 2005 phpBB Group
Deutsche Übersetzung von phpBB.de