Servercommunity Foren-Übersicht Servercommunity
Das informative Forum für Fragen rund um Server
 
 FAQFAQ   SuchenSuchen   MitgliederlisteMitgliederliste   BenutzergruppenBenutzergruppen   RegistrierenRegistrieren 
 ProfilProfil   Einloggen, um private Nachrichten zu lesenEinloggen, um private Nachrichten zu lesen   LoginLogin 

Update Problem -> Debian Sarge

 
Neues Thema eröffnen   Neue Antwort erstellen    Servercommunity Foren-Übersicht -> Alles andere
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
AndyG



Anmeldedatum: 29.06.2003
Beiträge: 603
Wohnort: Ruhrpott

BeitragVerfasst am: So Mai 07, 2006 10:12    Titel: Update Problem -> Debian Sarge Antworten mit Zitat

Hi,
folgende Auffälligkeit hab ich heute beim Updaten meines Vservers festgestellt.

OS: Debian Sarge

apt-get upgrade bringt folgende Meldung:
Zitat:
Reading Package Lists... Done
Building Dependency Tree... Done
The following packages have been kept back:
courier-maildrop libsasl2 libsasl2-dev libsasl2-modules libsasl2-modules-sql

Die Meldung über "courier-maildrop" ist in Ordnung, das hab ich wegen SysCP so eingerichtet. Aber was könnte es für Ursachen haben das die "libsasl" - Sachen nicht mehr erneuert werden?
Ich habe seit dem nichts mehr über den Paketmanager installiert. Gibt es Mechanismen die das automatisch einrichten.

[EDIT] Zum Updaten hab ich den Paketmanager natürlich regelmäßig benutzt!
_________________
Gruß
Andy

Das Leben ist gefährlich,.....,man kann dabei umkommen....!
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen
nobody



Anmeldedatum: 23.06.2003
Beiträge: 462

BeitragVerfasst am: Di Mai 09, 2006 14:28    Titel: Antworten mit Zitat

probier mal ein dist-upgrade anstatt nur upgrade, vielleicht hilft das.
_________________
Rechtschreibfehler gefunden? Pech, ich darf das. Ärztlich beglaubigter Legastekniker eh legassthenicker ..ehr auch scheiß wort. ich darf dat
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
AndyG



Anmeldedatum: 29.06.2003
Beiträge: 603
Wohnort: Ruhrpott

BeitragVerfasst am: Di Mai 09, 2006 16:01    Titel: Antworten mit Zitat

Hi,
Danke das hat funktioniert. Kann mir einer erklären warum?
Es wurden nur die "libsasl" Dinger erneuert. "courier-maildrop" wurde fein in Ruhe gelassen. Jetzt muß ich mich doch mal drum kümmern was "dist-upgrade" so macht. Ich dachte man erneuert das komplette OS auf eine neue Version.
_________________
Gruß
Andy

Das Leben ist gefährlich,.....,man kann dabei umkommen....!
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen
nobody



Anmeldedatum: 23.06.2003
Beiträge: 462

BeitragVerfasst am: Mi Mai 10, 2006 18:47    Titel: Antworten mit Zitat

der unterschied is recht simpel.
bei upgrade wird nur geschaut, ob eine neu version vorhanden ist und diese dann Versucht zu installieren, sollten sich nun abhänigkeiten ändern so werden diese nicht aufgelöst und somit wird das Packet dann auf hold gesetzt.

bei dist-upgrade wird, wie bei upgrade, geschaut, ob eine neue version vorhanden ist und diese dann installiert, sollten sich in diesem Fall abhängikeiten eines Paketes geändert haben, wird versucht diese best möglich aufzulösen.

daher sollte man, wenn man auf eine andere Version, z.b.: unstable, wechseln will, ein dist-upgrade durchführen.
_________________
Rechtschreibfehler gefunden? Pech, ich darf das. Ärztlich beglaubigter Legastekniker eh legassthenicker ..ehr auch scheiß wort. ich darf dat
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
AndyG



Anmeldedatum: 29.06.2003
Beiträge: 603
Wohnort: Ruhrpott

BeitragVerfasst am: Mi Mai 10, 2006 20:03    Titel: Antworten mit Zitat

Besten Dank,
ich muß zugeben um dist-upgrade hab ich mich bis jetzt noch nicht gekümmert Very Happy
_________________
Gruß
Andy

Das Leben ist gefährlich,.....,man kann dabei umkommen....!
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen
Beiträge der letzten Zeit anzeigen:   
Neues Thema eröffnen   Neue Antwort erstellen    Servercommunity Foren-Übersicht -> Alles andere Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehe zu:  
Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.



Powered by phpBB © 2001, 2005 phpBB Group
Deutsche Übersetzung von phpBB.de