Servercommunity Foren-Übersicht Servercommunity
Das informative Forum für Fragen rund um Server
 
 FAQFAQ   SuchenSuchen   MitgliederlisteMitgliederliste   BenutzergruppenBenutzergruppen   RegistrierenRegistrieren 
 ProfilProfil   Einloggen, um private Nachrichten zu lesenEinloggen, um private Nachrichten zu lesen   LoginLogin 

Datenbank fehler 1064

 
Neues Thema eröffnen   Neue Antwort erstellen    Servercommunity Foren-Übersicht -> Datenbanken
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
maniac



Anmeldedatum: 07.12.2005
Beiträge: 3

BeitragVerfasst am: Mi Dez 07, 2005 16:19    Titel: Datenbank fehler 1064 Antworten mit Zitat

#1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'collate latin1_general_ci NOT NULL default '',
`entry_company


Diesen Fehler bekomme wenn ich mein phpMyAdmin aufrufe und in ne leere Datenbank ne andere Datenbank einfügen will. Habe es mit dem SQL befehl gemacht. Liegt der fehler an mir oder am System?
Kann mir jemand helfen?

danke schon mal....

gruß

Maniac
_________________
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen MSN Messenger
Dennis
Junior-Chef


Anmeldedatum: 21.06.2003
Beiträge: 2344
Wohnort: Schömberg (zw. Stuttgart u . Karlsruhe)

BeitragVerfasst am: Mi Dez 07, 2005 16:30    Titel: Antworten mit Zitat

Fehler sieht nach ner falschen SQL-Syntax aus...aber genau sagen kann ichs auch nicht...einer der DB-Spezialisten da?
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen
maniac



Anmeldedatum: 07.12.2005
Beiträge: 3

BeitragVerfasst am: Mi Dez 07, 2005 19:25    Titel: Antworten mit Zitat

ich glaub da ist ne alte version auf dem server. diese wollte ich schon updaten aber damit hab ich nur probleme gehabt und musste den kompletten server plattmachen weil ich kein passendes backup hatte *argh*

wenn mir jemand sagen könnte wie ich dieses updaten kann ohne probleme dann wäre ich ja auch schon mal dankbar.
_________________
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen MSN Messenger
Dennis
Junior-Chef


Anmeldedatum: 21.06.2003
Beiträge: 2344
Wohnort: Schömberg (zw. Stuttgart u . Karlsruhe)

BeitragVerfasst am: Do Dez 08, 2005 09:02    Titel: Antworten mit Zitat

mysql ?
Was für ein OS hast denn drauf, eigentlich ist ein Update kein Problem...
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen
maniac



Anmeldedatum: 07.12.2005
Beiträge: 3

BeitragVerfasst am: Do Dez 08, 2005 09:54    Titel: Antworten mit Zitat

hab suse 9.2 drauf, aber wie gesagt, nach nem suse-online-update per yast, ging es nicht mehr oder nur noch zum teil. kenn mich auch nicht wirklich aus mit linux lol
_________________
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen MSN Messenger
Dennis
Junior-Chef


Anmeldedatum: 21.06.2003
Beiträge: 2344
Wohnort: Schömberg (zw. Stuttgart u . Karlsruhe)

BeitragVerfasst am: Do Dez 08, 2005 10:37    Titel: Antworten mit Zitat

hm also YOU sollte schon problemlos durchlaufen...ich würde den Kernel vielleicht nicht updaten lassen weil dein Provider vielleicht einen eigenen einsetzt.
Erzähl mal ein bischen über die Kiste, wo sie steht was drauf läuft etc.
Du solltest dich halt schon ein wenig mit Linux befassen wenn du einen Server administrieren willst...
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen
Henning



Anmeldedatum: 23.06.2003
Beiträge: 1541
Wohnort: Vienna, AT

BeitragVerfasst am: Do Dez 08, 2005 11:28    Titel: Antworten mit Zitat

Ich werd überhaupt nicht schlau daraus, wobei der Fehler auftritt?
Du hast MySQL geupdated und jetzt geht ganz MySQL nicht mehr? Oder hast du PHPMyAdmin geupdated und das wiederum will nicht mehr? Oder hat dein OS nen schlechten Tag und will nicht mehr?
Bitte beschreib doch den Fehler mal ausführlicher.
Vorallem WAS hast du vorher eingesetzt, WOHIN hast du geupdated und WIE / WANN tritt der Fehler auf Smile
Dann können dir bestimmt auch mehr Leute helfen.
_________________
Hallooooo Spongebob!
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
Dennis
Junior-Chef


Anmeldedatum: 21.06.2003
Beiträge: 2344
Wohnort: Schömberg (zw. Stuttgart u . Karlsruhe)

BeitragVerfasst am: Do Dez 08, 2005 12:24    Titel: Antworten mit Zitat

Schreibt der doch:

Bei einem Update hats ihm alles zerschossen also neu aufgesetzt.

Er hat also ein frisches System. Der Fehler passiert:

Zitat:
Diesen Fehler bekomme wenn ich mein phpMyAdmin aufrufe und in ne leere Datenbank ne andere Datenbank einfügen will.
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen
Henning



Anmeldedatum: 23.06.2003
Beiträge: 1541
Wohnort: Vienna, AT

BeitragVerfasst am: Do Dez 08, 2005 12:32    Titel: Antworten mit Zitat

Ja toll, die Beschreibung ist so hilfreich wie: "Ich hab nen Eimer Wasser in nen leeren Eimer gekippt, aber der ist übergelaufen. Warum?"
Das SQL Create Skript an der Stelle wäre mal handfest um den Fehler in der Syntax nachzuvollziehen, aber wenn ihr lieber esotherisch vorgeht, bitte Very Happy
_________________
Hallooooo Spongebob!
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
AndyG



Anmeldedatum: 29.06.2003
Beiträge: 603
Wohnort: Ruhrpott

BeitragVerfasst am: Do Dez 08, 2005 20:50    Titel: Antworten mit Zitat

Die Frage ist doch erst mal, wie fügst du denn die vorhanden Datenbank in die leere Datenbank ein. Du schreibst "mit dem SQL Befehl". Wie sieht der aus? Poste einfach mal den SQL Befehl der scheitert.
_________________
Gruß
Andy

Das Leben ist gefährlich,.....,man kann dabei umkommen....!
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen
Anton



Anmeldedatum: 02.05.2004
Beiträge: 173
Wohnort: Massing

BeitragVerfasst am: Fr Dez 09, 2005 10:47    Titel: Antworten mit Zitat

da ich genau solche errors letztens erst hatte, is das problem relativ "einfach" ...


"collate latin1_general_ci" is n befehl aus mysql 4.1 ... du hast aber mysql4.0, welches damit nix anfangen kann ...


den dump auf nen anderen server gemacht? ... und jetzt probiert, einzuspielen? ...


n manuelles downgrade von 4.1 auf 4.0 (was ich gemacht hab, systemweit läuft 4.0 und wird weiter laufen) können wir wohl ausschließen, das wüsstest du sicher noch Mr. Green


abhilfe?

dump mit ultraedit oder anderen linux-zeilenumbruch-fähigen editor öffnen ...

und alles, was mit "charset" oder sowas zu tun hat, rauslöschen ...

u.a. bei den spaltentypen - so ca:

`blabla`VARCHAR (3) collate latin1_general_ci NOT NULL DEFAULT '',

da den teil mit "collate latin1_general_ci" löschen ...

am ende der create table-syntax:

TYPE=MyISAM DEFAULT CHARSET=latin1

da "DEFAULT CHARSET=latin1" entfernen ...


den rest sagt das mysql-handbuch Wink
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
Beiträge der letzten Zeit anzeigen:   
Neues Thema eröffnen   Neue Antwort erstellen    Servercommunity Foren-Übersicht -> Datenbanken Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehe zu:  
Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.



Powered by phpBB © 2001, 2005 phpBB Group
Deutsche Übersetzung von phpBB.de