Servercommunity Foren-Übersicht Servercommunity
Das informative Forum für Fragen rund um Server
 
 FAQFAQ   SuchenSuchen   MitgliederlisteMitgliederliste   BenutzergruppenBenutzergruppen   RegistrierenRegistrieren 
 ProfilProfil   Einloggen, um private Nachrichten zu lesenEinloggen, um private Nachrichten zu lesen   LoginLogin 

Mailserver: mit DE Domain geht es und mit COM geht es nich..
Gehe zu Seite Zurück  1, 2, 3
 
Neues Thema eröffnen   Neue Antwort erstellen    Servercommunity Foren-Übersicht -> Mail
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Boum



Anmeldedatum: 29.07.2003
Beiträge: 1929
Wohnort: Karlsruhe

BeitragVerfasst am: Di März 15, 2005 14:48    Titel: Antworten mit Zitat

Keine Ahnung. Ich weiss nicht, wo die Dateien bei Dir liegen. Oder welche da liegen müssen. Sorry, aber ich bin weder ein Fan noch ein profunder Kenner von sendmail. Ich habe auch keins, bei dem ich nachschauen könnte. Local-host-names ist ein plain-Text-File, und gar keine .db. Vielleicht ist was in access und access.db futsch, oder, oder, oder.

Ernsthaft: Versteh' mich bitte nicht falsch, ich helfe gerne, aber langsam denke ich, Du solltest Dir die Konfiguration von sendmail mal gründlich anlesen. Und nicht per try and error "erforschen". Das kann nämlich blitzartig in's Auge gehen.
_________________
Planung ist das Ersetzen des Zufalls durch Irrtum.
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen AIM-Name
mario37



Anmeldedatum: 30.03.2004
Beiträge: 129
Wohnort: Aue

BeitragVerfasst am: Di März 15, 2005 15:15    Titel: Antworten mit Zitat

ich glaube, der Fehler ist in diesem Fall nicht bei Sendmail zu suchen. Der Support von S4F schreibt was von einem MX Record? wie hilfreich und Freundlich die Jungs vom Support sind, kann sich jeder selbst ausmalen. Für alle, die es Interessiert, poste ich mal das komplette Ticket, da ich es unfair finde, wie die sich verhalten.
Code:

Fehlerbeschreibung: beim senden von Mail an joes-freizeithallen.com erscheint immer eine Fehlermeldung. Das Problem tritt nur bei dieser Domain auf. Diese Domain wurde vor kurzem erst hinzugefügt.
Fehlermeldung: ----- The following addresses had permanent fatal errors -----
<info@joes-freizeithallen.com>
(reason: 553 5.3.5 system config error)

----- Transcript of session follows -----
553 5.3.5 mail.joes-freizeithallen.com. config error: mail loops back to me (MX problem?)
554 5.3.5 Local configuration error
 

--------------------------------------------------------------------------------
 

Verfasser Nachricht
Henrik Hasenkamp
2005-03-14 08:53:11 Sehr geehrter Kunde,

teilen Sie mir bitte ein SMTP Konto mit, mit welchem ich den Versand einer e-Mail an die entsprechende Adresse testen kann.

Mit freundlichen Grüßen
Henrik Hasenkamp
Hr. Schüler
2005-03-14 09:22:55 web16p1

info@joes-freizeithallen.com
service@joes-freizeithallen.com
Henrik Hasenkamp
2005-03-14 09:59:39 Sehr geehrter Kunde,

verzeihen Sie bitte, ich hatte mich nicht klar genug ausgedrückt. Selbstverständlich benötige ich auch das Zugangspasswort für den entsprechenden Account.

Mit freundlichen Grüßen
Henrik Hasenkamp
Hr. Schüler
2005-03-14 10:04:57 passwort habe ich soeben auf xxxx gesetzt

das senden einer E-Mail an eine dieser Adressen führt übrigens auch zu Fehlermeldung.
Henrik Hasenkamp
2005-03-14 12:06:56 Sehr geehrter Kunde,

der e-Mail Server funktioniert einwandfrei, der Fehler muss daher auf Ihrer Seite liegen.
hh@krabbe:~$ telnet 157046.vserver.de 25
Trying 62.75.157.46...
Connected to xxxxxx.
Escape character is '^]'.
ehlo test.de
220 vs157046.vserver.de ESMTP Sendmail 8.12.10/8.12.10; Mon, 14 Mar 2005 12:02:4
9 +0100
250-vs157046.vserver.de Hello [62.75.200.59], pleased to meet you
250-ENHANCEDSTATUSCODES
250-PIPELINING
250-8BITMIME
250-SIZE
250-DSN
250-AUTH GSSAPI DIGEST-MD5 CRAM-MD5 LOGIN PLAIN
250-DELIVERBY
250 HELP
AUTH LOGIN
d2ViMTZwMQ==
MDgxNTAw
334 VXNlcm5hbWU6
334 UGFzc3dvcmQ6
235 2.0.0 OK Authenticated
mail from: info@joes-freizeithallen.com
250 2.1.0 info@joes-freizeithallen.com... Sender ok
rcpt to: hh@plusserver.de
250 2.1.5 hh@plusserver.de... Recipient ok
data
354 Enter mail, end with "." on a line by itself
subject: test
das hier ist ein test
.
250 2.0.0 j2EB2dmA029827 Message accepted for delivery


Mit freundlichen Grüßen
Henrik Hasenkamp
Hr. Schüler
2005-03-14 12:32:16 da der fehler erst nach bestellung und nutzung der domain joes-freizeithallen.com auftritt und der Mailserver vorher tadellos ging, kann der Fehler nicht auf meiner Seite liegen. Ich habe die Domain
joes-freizeithallen.com nicht eingetragen.sondern S4Y. Anscheinend besteht ein Problem mit den Eintragungen der Domain joes-freizeithallen.com von Seiten S4Y. Bitte überprüfen Sie die Angelegenheit nochmals.
Hr. Schüler
2005-03-14 13:03:05 il[1154]: AUTH=server, relay=p54884C34.dip0.t-ipconnect.de [84.136.76.52], authid=web14p24, mech=LOGIN, bits=0
Mar 14 13:02:39 vs157046 sendmail[1154]: j2EC2amA001154: from=<studio@rof-aue.de>, size=1128, class=0, nrcpts=1, msgid=<002001c5288d$ba0d70f0$5399fea9@pc1>, proto=ESMTP, daemon=MSA, relay=p54884C34.dip0.t-ipconnect.de [84.136.76.52]
Mar 14 13:02:39 vs157046 sendmail[1154]: j2EC2amA001154: Milter add: header: X-AntiVirus: checked by AntiVir Milter (version: 1.1.0-4; AVE: 6.30.0.5; VDF: 6.30.0.27; host: vs157046.vserver.de)
Mar 14 13:02:40 vs157046 sendmail[2816]: j2EC2amA001154: SYSERR(root): mail.joes-freizeithallen.com. config error: mail loops back to me (MX problem?)
Mar 14 13:02:40 vs157046 sendmail[2816]: j2EC2amA001154: to=<info@joes-freizeithallen.com>, ctladdr=<studio@rof-aue.de> (654/102), delay=00:00:01, xdelay=00:00:01, mailer=esmtp, pri=31128, relay=mail.joes-freizeithallen.com. [62.75.157.46], dsn=5.3.5, stat=Local configuration error
Mar 14 13:02:40 vs157046 sendmail[2850]: j2EC2emA002850: vs157046.vserver.de [62.75.157.46] did not issue MAIL/EXPN/VRFY/ETRN during connection to MSA
Mar 14 13:02:40 vs157046 sendmail[2816]: j2EC2amA001154: j2EC2emA002816: DSN: Local configuration error
Mar 14 13:02:40 vs157046 sendmail[2816]: j2EC2emA002816: to=<studio@rof-aue.de>, delay=00:00:00, xdelay=00:00:00, mailer=local, pri=62267, dsn=2.0.0, stat=Sent
Mar 14 13:02:40 vs157046 sendmail[2816]: j2EC2emA002816: to=root, delay=00:00:00, xdelay=00:00:00, mailer=local, pri=62267, dsn=2.0.0, stat=Sent


so schaut der versuch aus, eine e-mail an info@joes-freizeithallen.con zu senden. Also jeder der an diese Adresse senden will, bekommt eine Fehlermail zurück ->

The original message was received at Mon, 14 Mar 2005 13:02:39 +0100
from p54884C34.dip0.t-ipconnect.de [84.136.76.52]

----- The following addresses had permanent fatal errors -----
<info@joes-freizeithallen.com>
(reason: 553 5.3.5 system config error)

----- Transcript of session follows -----
553 5.3.5 mail.joes-freizeithallen.com. config error: mail loops back to me (MX problem?)
554 5.3.5 Local configuration error
Henrik Hasenkamp
2005-03-14 13:13:11 Sehr geehrter Kunde,

wir sind nicht dafür Zuständig Ihre DNS Rekords zu verwalten. Dieses können und müssen Sie selber machen. Hierfür steht Ihnen unser Interface zur Verfügung.
Da ein Fehler auf unserer Seite ausgeschlossen werden kann, biete ich Ihnen die weitere Analyse gegen Berechnung an. Sollten sich dabei dann fehlerhafte Einstellungen herausstellen, korrigiere ich diese mit Ihrer Absprache. Bestätigen Sie hierzu bitte eine Arbeitseinheit zu 39 Euro.

Mit freundlichen Grüßen
Henrik Hasenkamp

_________________
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden
Boum



Anmeldedatum: 29.07.2003
Beiträge: 1929
Wohnort: Karlsruhe

BeitragVerfasst am: Di März 15, 2005 16:10    Titel: Antworten mit Zitat

Nur ganz kurz:

ich hatte vorhin den Fehler
Code:
Relaying denied. Proper authentication required.

...und nicht mehr den hier:
Code:
config error: mail loops back to me (MX problem?)


IMHO ist das nicht S4Ys Konfigurationsproblem mehr. Aber ich kann mich irren...
_________________
Planung ist das Ersetzen des Zufalls durch Irrtum.
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen AIM-Name
mario37



Anmeldedatum: 30.03.2004
Beiträge: 129
Wohnort: Aue

BeitragVerfasst am: Di März 15, 2005 16:34    Titel: Antworten mit Zitat

beim versuch, eine Mail an test@joes-freizeithallen.com zu senden kommt jedesmal:

Code:

The original message was received at Tue, 15 Mar 2005 16:23:12 +0100
from p548846F1.dip0.t-ipconnect.de [84.136.70.241]

   ----- The following addresses had permanent fatal errors -----
<test@joes-freizeithallen.com>
    (reason: 553 5.3.5 system config error)

   ----- Transcript of session follows -----
553 5.3.5 mail.joes-freizeithallen.com. config error: mail loops back to me (MX problem?)
554 5.3.5 Local configuration error


kann gern getestet werden
_________________
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden
Boum



Anmeldedatum: 29.07.2003
Beiträge: 1929
Wohnort: Karlsruhe

BeitragVerfasst am: Di März 15, 2005 16:59    Titel: Antworten mit Zitat

Und das hier kommt von einem externen Rechner aus, wenn man versucht, die Mail zuzustellen:
Code:

This is the Postfix program at host wombat.netzzentrum.de.

I'm sorry to have to inform you that the message returned
below could not be delivered to one or more destinations.

For further assistance, please send mail to <postmaster>

If you do so, please include this problem report. You can
delete your own text from the message returned below.

                        The Postfix program

<test@joes-freizeithallen.com>: host mail.joes-freizeithallen.com[62.75.157.46]
    said: 550 5.7.1 <test@joes-freizeithallen.com>... Relaying denied. Proper
    authentication required. (in reply to RCPT TO command)


Problem ist, dass Du beim Versuch, die Mail zu schicken, natürlich auch auf dem Server bist. Insofern kommt da eine andere Fehlermeldung, zumal Du Dich ja authentifizierst, um die Mail abzusetzen.

In meinem Fall versucht ein externer Rechner, die Mail bei Deinem Server loszuwerden. Dazu kommt es aber erst gar nicht, weil mein Server schon beim RCPT TO: geblockt wird. Wenn Du sendest, nimmt der Rechner eh alle Mails an, die Du ihm fütterst, weil Du Dich per Passwort angemeldet hast. Und dann staunt er, dass er die Mail an sich selber schicken soll...
_________________
Planung ist das Ersetzen des Zufalls durch Irrtum.
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen AIM-Name
O.P.



Anmeldedatum: 21.06.2003
Beiträge: 835

BeitragVerfasst am: Mi März 16, 2005 17:12    Titel: Antworten mit Zitat

Steht in der Datei /etc/mail/local-host-names die Domain drin?

Ich weiss nicht was Confixx mit der Datei veranstaltet (also ob Confixx die Datei nutzt oder eine eigene includet) aber bei Sendmail ist dies die Datei, welche alle Domains, die lokal von dem Server behandelt werden enthalten muss.
Achtung: Diesen Eintrag muss Confixx normalerweise automatisch erledigen!
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
mario37



Anmeldedatum: 30.03.2004
Beiträge: 129
Wohnort: Aue

BeitragVerfasst am: Mi März 16, 2005 17:22    Titel: Antworten mit Zitat

ja, diese Domain ist dort eingetragen.
_________________
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden
O.P.



Anmeldedatum: 21.06.2003
Beiträge: 835

BeitragVerfasst am: Mi März 16, 2005 17:23    Titel: Antworten mit Zitat

mario37 hat Folgendes geschrieben:
ja, diese Domain ist dort eingetragen.

Dann sollten mails an die Domain auch direkt geroutet werden.
Hast du Sendmail mal neu gestartet?
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
mario37



Anmeldedatum: 30.03.2004
Beiträge: 129
Wohnort: Aue

BeitragVerfasst am: Mi März 16, 2005 17:33    Titel: Antworten mit Zitat

ja, half aber nix. sendmail läuft bei mir als daemon (-bd) wegen der RBL?s, die sonnst nicht funktionieren.
_________________
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden
O.P.



Anmeldedatum: 21.06.2003
Beiträge: 835

BeitragVerfasst am: Mi März 16, 2005 21:01    Titel: Antworten mit Zitat

mario37 hat Folgendes geschrieben:
ja, half aber nix. sendmail läuft bei mir als daemon (-bd) wegen der RBL?s, die sonnst nicht funktionieren.


Die Fehlermeldung ist eigendlich ziemlich eindeutig und deutet darauf hin, das die Domain joes-freizeithallen.com nicht in der /etc/mail/local-host-names enthalten ist.
Ist die da wirklich korrekt geschrieben drin? keine Zeichen dahinter etc.?

Für die Domain ist als Mailexchanger der Server mit der IP 62.75.157.46 zuständig. Wenn das die IP deines Servers ist, ist dier Domain und Nameservereintrag des Providers korrekt.
Der Server 62.75.157.46 nimmt Mails für die Domain nicht an, weil er sich für die Domain nicht zuständig fühlt (Mails von aussen werden als "Relaying denied" abgewiesen, Mails von authentifizierten Usern, die ralyen dürfen, werden mit der Fehlermledung "Mail loops back to me" beantwortet, da er versucht die Mails an den für die Domain zuständigen Mailexchanger zuzustellen und dabei merkt, das er "an sich selbst" zustellen will). Eindeutig die /etc/mail/local-host-names , in der alle Domains eingetragen sein müssen, für die dein Sendmail zuständig sein soll)
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
O.P.



Anmeldedatum: 21.06.2003
Beiträge: 835

BeitragVerfasst am: Mi März 16, 2005 21:33    Titel: Inhalt der /etc/mail/localhostnames Antworten mit Zitat

Mario hat mir per PM den Inhalt der /etc/mail/local-host-names geschickt.
Hmmm. dort ist die Domain eindeutig enthalten.
Ich kann dir nur raten die Domain nochmal zu löschen und neu einzutragen. irgendwo ist der Wurm drin.
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
O.P.



Anmeldedatum: 21.06.2003
Beiträge: 835

BeitragVerfasst am: Mi März 16, 2005 21:40    Titel: Antworten mit Zitat

mario37 hat Folgendes geschrieben:
Das Problem ist ja insofern seltsam, da ich mit einer angelegten testadresse von der Domain ja E-Mail senden kann und die dann auch ankommen. N U R empfangen will die Domain / E-Mail Adresse absolut nix. Wenn ich aber senden kann, muss SM ja wissen, wer die domain ist?
Embarassed

Nö, die Absenderdomain ist sednmail ziemlich egal solange du dich korrekt anmeldest. Du kannst als Absenderadresse aus willi_wichtig@bundeskanzleramt.info nehmen so was weiss ich. Solange du dich mit einem gültigen Benutzernamen und Kennwort anmeldest wird er die Mail weiterleiten.
Das "Senden" geht ist also kein Anzeichen dafür das er die Domain kennt.
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
O.P.



Anmeldedatum: 21.06.2003
Beiträge: 835

BeitragVerfasst am: Mi März 16, 2005 21:54    Titel: Antworten mit Zitat

mario37 hat Folgendes geschrieben:
habe nur make laufen lassen und m4 zur sicherheit auch noch mal mit.


-> /etc/sendmail.cf sichern
m4 /etc/mail/[sendmail-konfigurationsdatei im klartext] > /etc/sendmail.cf

Mit [sendmail-konfigurationsdatei im klatext] ist die unübersetzte Konfigurationsdatei gemeint. Bei mir (SuSE) heisst die linux.mc
Die Datei hat meist die Endnung .mc

Ich glaube bei RedHat heisst die sendmail.mc , bin mir aber nicht sicher.
Falls ja - Beispiel:

cp /etc/sendmail.cf /etc/sendmail.bak
m4 /etc/mail/sendmail.mc > /etc/sendmail.cf
service sendmail restart (bei SUSE rcsendmail restart)

Könnte auch "config.mc" heissen.

Besser erscheint mir aber die Domain in Confixx nochmal zu löschen und wieder einzurichten. Ich weiss nicht wie Confixx arbeitet.
Soweit mir in Erinnerung läuft der Admin.Task von Confixx chronologisch - Änderungen in Confixx werden also nicht sofort wirksam.
Nach oben
Benutzer-Profile anzeigen Private Nachricht senden
Beiträge der letzten Zeit anzeigen:   
Neues Thema eröffnen   Neue Antwort erstellen    Servercommunity Foren-Übersicht -> Mail Alle Zeiten sind GMT + 1 Stunde
Gehe zu Seite Zurück  1, 2, 3
Seite 3 von 3

 
Gehe zu:  
Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.



Powered by phpBB © 2001, 2005 phpBB Group
Deutsche Übersetzung von phpBB.de